1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
    Information ausblenden
  3. Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
    Information ausblenden

Face "0" festlegen

Dieses Thema im Forum "Objekte & Modellieren" wurde erstellt von Vin Vaniva, 26. November 2014.

  1. Vin Vaniva

    Vin Vaniva Nutzer

    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich hab da gerade ein Problem mit meinen Meshmodellen ... bzw. ein sporadisches Problem.
    Ich erstelle Meshmodelle und weise unterschiedlichen Flächen unterschiedliche Materialien zu. So bekommt man ja dann nach dem Import in SL für jedes Material eine eigene Fläche. So kann ich für kleine Teile Flächen erstellen, die weit vom eigentlich Objekt entfernt sind, so dass ich das Modell stark verkleinern kann und diese Flächen dann auf 100% Transparent setze.
    Nun ist es so, dass man, um das Objekt per Rechtsklick anklicken und das Bearbeiten-Fenster öffnen zu können, man die Fläche "0" erwischen muss. In meinem aktuellen Modell ist das allerdings leider eine, die ich transparent machen will / muss.
    Wie kann ich denn im Blender die Reihenfolge der Materialen / späteren Flächen vor dem Export beeinflussen?

    Hier jetzt nicht ganz nen Problem, aber wenn ich z.B. im Blender mehrere Objekte habe, die ich alle Markiere und dann per Export das SL-Mesh-Modell erstelle, wird immer "irgendeins" nach dem Import in SL zum root-Prim. Scheinbar ist es völlig irrelevant, in welcher Reihenfolge ich die Objekte vor dem Export im Blender markiere. Hier die arg ähnliche Frage: Wie kann ich im Blender vor dem Import beeinflussen, welches Objekt zum root-Prim nach dem Import in SL wird?
    (Wobei der WorkAround hier ist, das Modell wieder zu "unlinken" und dann das Prim, welches zum root-Prim werden soll, ab- und wieder anzuwählen, wo durch es zum zuletzt markierten Prim und damit beim wieder verlinken zum root-Prim wird.)

    Danke schon mal für Eure Hilfe.
     
  2. Strandwind Resident

    Strandwind Resident Nutzer

    Beiträge:
    81
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Ohne wesentlich zu wissen, was los ist, wäre mein Vorschlag: Kannst du das Objekt nicht inworld (kurzfristig) größer machen und dort den root-prim (durch erneutes Verlinken) festlegen?
     
  3. Jenna Felton

    Jenna Felton Superstar

    Beiträge:
    1.995
    Zustimmungen:
    57
    Punkte für Erfolge:
    64
    Edit: Sehr komisch. Ich muss überlesen haben, dass es ums Root prim geht und nicht Zusammenfassen von Obkekten im Blender zu einem. Aber vielleicht braucht wer die Antwort trotzdem, daher nicht lösche.

    Hallo Vin, also ich hatte gerade mehrere Objekte in Blender zu einem verschmolzen. Und diese Beobachtung gemacht:

    Markiere ich ein Objekt (Rechtsklik in Objektmodus), dann drücke ich A zweimal (beim ersten Mal wird alles abgewählt, beim Zweiten ausgewählt), und ducke auf Strg+J fürs Verschmelzen, dann werden die Materialien der anderen Objekte hinter denen des zuerst ausgewählten Objektes angeordnet, d.H. bekommen dann höheren Facenummern.

    Ich hatte aber immer nur zwei Objekte so zusammengefasst, der Rest war unsichtbar und wurde dazugeschaltet, damit konnte ich so beeinflussen welche Faces wo stehen. Nach dem ersten Verschmelzen war das Gesamtobjekt schon ausgewählt, so dass ich nur das Nächste sichtbar stellen und per Doppel-A zur Auswahl hinzufügen musste, also braucht man nicht mehr mit RMB ankliken.

    Der Blender ist 2.68a, falls das wichtig ist.

    Wenn ich irgendwann feststelle, dass die Materielein falsch angeordnet sind und ich nicht alles neu machen möchte, dann geht das Umordnen relativ einfach so:

    Ich füge ein neues Materiel ein, dann wähle alles ab, wähle Material aus das ich nach hinten verschieben möchte (in der Materieleinliste), dann über Select werden Faces des Materials ausgewählt und per Assign dem neuen Material zugewiesen. Dann wähle ich das Material, das ich vorne sehen möchte und verlege auf gleiche Weise auf den frei gewordenen Material.

    Mit acht erlaubten Materialein ist das relativ einfach. Am Ende lösche ich das hinzugefügte Material im Objektmodus.
     
    Zuletzt bearbeitet: 27. November 2014
  4. Jenna Felton

    Jenna Felton Superstar

    Beiträge:
    1.995
    Zustimmungen:
    57
    Punkte für Erfolge:
    64
    Und es geht doch :)

    Also ich habe gerade versucht, ich habe es so noch nie gemacht, aber es klappt tasächlich. Ich habe 5 Objekte im Blenderfile. Eigentlich 20, weil jedes liegt vor als High, Mid und Low LOD-Stufen plus Physik.

    Ich habe alle ausgeblendet, so dass sie nicht in der Szene sind. Camera und Licht sind bei mir gelöscht, aber ich denke ausblenden reicht auch.

    Jetzt habe ich alle High Stufen eingeblendet, Das Objekt das das Root sein soll habe ich direkt ausgewählt, dann zweimal A drücken, dann Export, dort den Preset "SL Static" gewählt aber "Include UV Textures" abgewählt, und als eine .dae Datei exportiert.

    Dasselbe mit den anderen zwei Stufen und Physik wiederholt. Dabei brauche ich dann den Preset nicht mehr zu wählen.

    Beim Import in Viewer habe ich die vier Dateien dann genommen, der Viewer hat die LOD Stufen ohne Problemme richtig zugeordnet. Die Flikerei mit Importieren jedes Mesh einzeln und verlinken inworld kann ich mir in Zukunft sparen :)

    Jedenfalls hat das Linkset und alle Prims zwar den falschen Namen, aber das Rootprim war das Objekt dass ich zuerst direkt ausgewählt hatte. Ich musste inworld die Prims richtig umbenennen, keine Anung warum die Namen nicht übernommen bzw. nicht richtig exportiert werden.

    LG
    Jenna
     
  5. Vin Vaniva

    Vin Vaniva Nutzer

    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi, danke schon mal für die Antworten.
    Ich muss das dann mal alles ausprobieren.
    Bzgl. des root-Prims war es bei mir leider nicht wirklich wiederholbar, dass immer das Objekt nach dem Import in SL das root-Prim ist, welches ich in blender zuerst markiert hatte.
    Aber ich werde noch mal etwas rumprobieren.

    Wenn ich das bzgl. der Faces richtig verstanden hab, ist bei dir Face 0 immer das Material, welches du zu letzt assignt hast?
     
  6. Jenna Felton

    Jenna Felton Superstar

    Beiträge:
    1.995
    Zustimmungen:
    57
    Punkte für Erfolge:
    64
    Nee, 0 ist immer das Material, was oben in der Liste steht, die Facenummern werden den Materielien in der Liste von oben nach unten vergeben.

    Oder Du meinst das beim Zusammenfassen der Objekte zu einem? Dann stehen im Gesamtobjekt die Materielien des Teilobjektes oben, welches ich zuerst ausgewählt hatte, nachdem ich es mit der A Taste abgewählt und mit erneuten A alles ausgewählt hatte und dann mit Strg+J zusammengefasst. Materielien des hinzugefügten Objektes stehen dann weiter unten. Irgendwie scheint der Blender es sich zu merken, welches Objekt ausgewählt war bevor alles markiert wurde.

    Auch das Rootprim wird so festgelegt anscheinend.
     
  7. Vin Vaniva

    Vin Vaniva Nutzer

    Beiträge:
    29
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ok ... ich probier das mal aus.

    Bisher hab ich immer die Objekte nach einander mit gedrückter Shift-Taste und Links-Click markiert und zusammengefügt. Dabei konnte ich aber irgendwie nicht so recht nachvollziehen, welches dann zum root wird, da es mal das zu erst markierte und mal das zu letzt markiert war. Ich konnt' es zumindest nie reproduzieren. Ich teste Deine "A-Tasten-Variante" mal. ;)

    Danke.
     
  8. Jenna Felton

    Jenna Felton Superstar

    Beiträge:
    1.995
    Zustimmungen:
    57
    Punkte für Erfolge:
    64
    Ich muss mich leider korrigieren. Die Methode mit doppel A hat für das Rootprim doch nicht funktioniert. Es scheint als würde es sich von mal zu mal ändern.

    Habe jetzt in Betagrid und dann auf meiner OS Sim dasselbe kombinirte Mesh hochgeladen und das Rootprim war nicht das was ich vor der doppel-A Methode ausgewählt hatte.

    Ich hatte das Objekt vom gestrigen Upload nochmal angeschaut, dort ist das Rootprim das richtige. Die benutzte Dateien sind die selben und umlinken hatte ich definitiv nicht getan. Ich hatte nur den Server zwischenzeitlich neu gestartet (der Rechner musste ja aus.)