• Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
  • Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
  • Wir verwenden Cookies, um Inhalte und Anzeigen zu personalisieren, Funktionen für soziale Medien anbieten zu können und die Zugriffe auf unsere Website zu analysieren. Sie geben Einwilligung zu unseren Cookies, wenn Sie unsere Webseite weiterhin nutzen.

Häufige Verbindungsabbrüche

Huhu,
isch hab da ma ein Problem^^ Hoffe hat da einen Rat für mich.

Aaaalso.. seit geraumer Zeit.. also einige Wochen... hat sich immer mehr eigeschlichen das ich Verbindgungsabbrüche hab in SL. Dabei werd ich nicht abgemeldet, SL ist wohl toleranter geworden was das angeht, aber ich sehe wie mein Packetloss hochschnellt, der Stream bricht ab, mein Internetsymbol von T-Online in der Taskleiste wird rot für einige Sekunden, und irgendwann gehts dann wieder weiter. Das hat erst ganz langsam angefangen, so alle paar Tage mal und war mit Modemrestart erstmal behoben, aber mitlerweile kämpfe ich so gut wie jeden Tag damit. Vorzugsweise wenn ich ich ne stabile Verbindung brauche, bei Events z.b., scheint meine Leitung einfach schlapp zu machen. Jetzt hab ich ja eh schon so ne schwachbrüstige Leitung (DSL Light, 384Kbs) aber das es so unstabil ist war vorher nicht.

Das komische daran ist, das es geradezu tageszeit abhängig zu sein scheint. Vor allem in den Abendstunden kommts mir besonders schlimm vor, später des nachts gehts dann oft wieder normal. Auch scheint es was mit SL zu tun zu haben, denn ich habs gestern mal probiert, solange ich den Viewer zugelassen hab konnte ich stabil dem Stream lauschen, aber sobald ich den Viewer (Firestorm und auch Phoenix) aufgemacht hab ging wieder alles auf rot und ich hab nur noch Sekundenweise Musik gehört - selbst als ich den Viewer auf 50kbs runtergedrosselt hab, was vom Datenvolumen dann nichts mehr ausmachen müsste (und bisher auch nicht hat. Normal stell ich den Viewer auf 200-300kbs und kann damit noch bequem den Stream hören).

zur Technik:

- ich benutze kein Wlan, ich hab alles mit Kabeln
- Speedtest sah nicht schlecht aus, schwankt bisschen von der DL-Rate her, aber sollte ausreichend sein. Das Problem sind wohl eher die Abbrüche. Die zeigt der Speedtest aber nicht.
- Telekom hat die Leitung bereits getestet und konnte nichts auffälliges finden
- Ich benutze WinXP
- kein Router, PC geht direkt ans Modem. Modem hat keine Benutzeroberfläche oder so. (Arcor Speedmodem 200)

Mein persönlicher Verdacht ist, dass das Modem den Geist aufgibt. Aber da es nur zeitweise zu sein scheint und besonders SL betrifft, bin ich nicht ganz sicher. Bevor ich mir jetzt ein neues Modem kaufe auf gut Glück, meine konkrete Frage an die Experten hier:

Gibts einen Weg irgendwie einzukreisen wo das Problem herkommt? Logs, Tools, irgendwas? Kanns vom Viewer kommen, irgendwelche Programme die im Hintergrund laufen (taskmanager zeigt nix besonderes an, Virusscanner hat nix gefunden), oder andere Ursachen haben (z.b. nachbarn die auch grad die Leitung benutzen)?

Danke schonmal für eure Hilfe.

Mania
 

Igel Hawks

Superstar
Ich hatte das ähnliche Problem und konnte nix finden. Durch Zufall habe ich dann den "Bösewicht" entdeckt: Das Flashplugin der Browser ist abgestürzt. Zur Erklärung: Ich habe eigentlich immer meinen Gmail Account geöffnet und bin da am Chatten mit Freunden, die nicht in SL sind. Irgendwann fiel mir dann auf, daß der Chrome den Absturz des Flashplugins gemeldet hat und ich dann kurz danach genau wie Du es beschrieben hast, beinahe aus SL geflogen bin (Stream fing an zu stottern, der Viewer sah normal aus, nur die Bewegungen waren eingefroren). Ich habe dann alle anderen Browser ausprobiert und genau dasselbe beobachtet. Seit dem letzten Flashupdate scheint es wieder besser zu laufen.
Vielleicht hilft das ja bei der Fehlersuche.
Kannst Du Dir nicht einen anderen Router zum Testen bei jemandem ausleihen?

Igelchen
 
Bei mir war der Router Schuld. Irgendwie dachte ich immer, das Problem müsse was mit Software zu tun haben, und konnte irgendwann keine Viertelstunde mehr in SL sein ohne Abflug. Als dann selbst WinSCP beim Upload auf meinen Mietserver nicht mehr klarkam, brachte ein neuer Router wieder Stabilität ins Netz.

Neue Hardware kaufen ist natürlich die letzte Option, aber auch da kann es hakeln.
 
X

Xenos Yifu

Guest
Du bist sicher das nicht dein INet gekappt wird?
Einfach mal die IP mehrmals bei so Effekten kontrollieren zB. Meine IP Adresse auf MeineIP.de
ändert die sich bricht die Leitung zusammen.

Das kann schon dadurch entstehen das sie zu viele Leute auf deinen Knotenpunkt schalten.

Bei mir waren es damals CRC-Fehler, bis zu 100 in der Minute, Telekom-DSL 16 000.
Der Techniker muss das aber vor Ort messen!

Mir wollten sie darauf hin einfach die Leitung so weit runterdrosseln (auf 6000) bis die CRC-Fehler aufhörten.
Ich habe die aber solange bearbeitet bis sie meine Leitung auf V-DSL 16000 umstellten
und mir kostenlos ein Router zu stellen ;)

Seit dem ist Ruhe.
 
Danke für die ersten Hilfsversuche :)

@Igel: gecheckt, Flash ist auf dem neusten Stand

@Mareta: Router hab ich doch garkeinen, nur Modem ohne Routerfunktion

@Xenos: Ja, Verbindungsabbrüche, schrieb ich doch^^


Was mir gerade aufgefallen ist auf Tip von nem Freund: Wenn ich "netstat" aufrufe sehe ich sehr viele(!) Verbindungen die auf "wartend" stehen, auch wenn Internetbrowser und SL geschlossen sind, also alles zu was mit Inet zu tun hat. Ist das normal?
 

Nicoletta Schnute

Forumsgott/göttin
Was mir gerade aufgefallen ist auf Tip von nem Freund: Wenn ich "netstat" aufrufe sehe ich sehr viele(!) Verbindungen die auf "wartend" stehen, auch wenn Internetbrowser und Second Life geschlossen sind, also alles zu was mit Inet zu tun hat. Ist das normal?

Jain ... Es können Updater Programme sein aber auch adware oder Trojaner. Um herauszufinden was für Verbindungen das sind müsstest Du sie mal aufschreiben.
Du kannst auch alle Hintergrundprogramme beenden (Icons in der Taskleiste) ausser den Virenscanner und schauen was dann noch übrig ist.
 
Das mit den CRC Fehler kapier ich irgendwie nicht.. wenn ich danach google kommen nur einträge rar-files betreffend.. und aus dem Forumpost da werd ich nicht schlau. Was ist ein CRC Fehler? Und kann ich das nicht selber testen oder sehen? der da im Beitrag konnts ja auch?

@Sven: Splitter wurde schon ausgetauscht, den gabs sogar kostenlos :D

@Nico: also wenn ich wirklich alles aus mache ist es um einiges weniger, mit IE offen gleich sehr viel mehr. Am allermeisten verbindet sich -Computername- mit Localhost auf dutzenden verschiedenen Ports. Auch ein paar nichtssagende IP´s, und was interessant war, ne Verbindung zu FB bei geschlossenem Browser^^

Gerade "rennt" die Leitung so richtig übrigens.. scheint einen guten Tag zu haben oder gute Stunde lol

Ahso, Spybot und Avast haben nix angezeigt, ich lass aber grad nochmal ne gründliche Prüfung laufen.

Gibts nicht irgendein tool oder logfile was Aussagen darüber machen könnte was mit der Verbindung nicht stimmt?
 

Nicoletta Schnute

Forumsgott/göttin
Toolbars könnten es noch sein.

Meine Empfehlung wäre mal ein Scan mit einem externen Scanner vom USB Stick.

Der IE macht viele Ports auf und ist immernoch anfälliger für Conterminierung als alle sonstigen Browser.
 

Lucky Bekkers

Forumsgott/göttin
Welchen Provider hast Du denn?
Ich frage das deshalb weil ich selber 1und1 habe und die keinen Splitter mehr benötigen.

Als Modem, als auch als Router kann ich nur eine Fritzbox wärmsten empfehlen.
 
Danke für die Aufklärung Maybeso ;)
Alles sehr technisch und hilft mir auch nicht wirklich von Fleck.

Ich wiederhol meine Frage nochmal: Gibts nicht irgendein tool oder logfile was Aussagen darüber machen könnte was mit der Verbindung nicht stimmt?
Denn so stocher ich mehr oder weniger im dunkeln rum.

Dennoch: Volständiger Avast Suchlauf ergab nichts.

@Maybeso: Ja, Packetloss ist definitiv da im viewer, wenn es mal wieder soweit ist. Dann kommen Packetloss und Abbruch Hand in Hand. Also ich hab ja den Balken im Firestorm, der dann rot wird. kurz darauf wird mein T-Com symbol auch rot, dann stockt alles für paar Sekunden, dann wird das Tcom Symbol wieder grün, und der Packetloss geht weg, für ein paar Sekunden, dann geht der Spaß von vorne los. Dabei hilfts übrigens auch nicht den Viewer auf 50kbs zu drosseln. Wenn die Verbindung erstmal im "abkackstatus" ist, hilft nur Modem resetten, und mit viel Glück läuft es danach besser. Das ist ja das komische, die Störung hört aus unersichtlichen Gründen irgendwann einfach auf. Aber immer nur nach Modemreset (manchmal auch nicht). Ohne Modemreset normalisiert sich die Verbindung nicht mehr. Manchmal läufts auch perfekt nach einem reset, und so bald ich SL aufmache, auch mit ganz niedriger Bandbreite, krachbumm gehts von vorne los. Ich kanns einfach nicht einkreisen, denke aber das es das Modem ist. Ich wollts nur genau wissen bevor ich mir ein neues kauf^^

@Nico keine schlechte Idee, hab bei den Browser Plugins einiges gefunden was im Hintergrund lief, hab mal paar Sachen deaktiviert.

@Lucky: bin bei Telekom, und wie gesagt, Splitter wurde ja schon ausgewechselt. Wenngleich das selbe fabrikat wie vorher.
 

Wiffelbottom Resident

Freund/in des Forums
Wirklich helfen kann ich dir leider nicht Mania. Aber ein Test der Leitung durch Techniker ist manchmal sinnvoll. Bei mir war bereits einmal ein ziemlich exotischer Fehler der dadurch gefunden wurde. Ein Ameisennest im Viertelverteiler. Jede geschmorte Ameise brachte dadurch Fehler und Abbrüche (vereinfacht ausgedrückt hat man mir das so erklärt).
Resultat war auch ein sporadisches und nur schwer feststellbares Aussetzen der Leitung das natürlich bei den Fernprüfungen nie aufgetreten ist.

Nur als Hinweis bevor du dich komplett neu ausstattest^^ - Das wollte man mir damals auch erst nahelegen.
 

Shirley Iuga

Forumsgott/göttin
huhu Mania, ja es gibt ein einfaches Tool, mit dem man sieht, wie viel Bandbreite man gerade hat usw:
Einfach in Windows den Task Manager aufmachen und im Tab Netzwerk mal reinschauen, da siehst du zu wie viel % dein Netzwerk ausgelastet ist. Wenn du z.B. eine 100Mbit Anbindung der Netzwerkkarte hast und dein Netzwerk zu 0.45% ausgelastet ist, dann sind das rund 45 kiB/s - und dein DSL light läuft voll ausgelastet. Anhand der Kurve siehst du auch wunderbar, ob du da einen Einbruch bei der Geschwindigkeit hast oder nicht.(Bei 1000MBit eben entsprechend 0.045%, aber die meisten DSL Modems haben nur eine 100 Mbit Ethernet Anbindung, manche alte sogar nur 10 Mbit, was dann eine 4,5% Auslastung wäre...)

Mach daher mal einen Test mit einem fetten Download und schau dabei mal die Download-Rate an. Und schau dir mal da an, wie sich deine Verbindung verhält. D.h. ob da auch noch Verbindungsabbrüche sind. Hier: ftp://ftp.uni-erlangen.de/pub/Linux....0.5/ia64/iso-dvd/debian-6.0.5-ia64-DVD-1.iso gibts z.B. eine 4GB große DVD mit debian von einem Server, der konstant deine kleine DSL Leitung zu 100% auslasten kann. Wenn das problemlos geht ohne dass deine Verbindung abbricht, dann liegt es wohl an SL. Denn der SL-Viewer hat nicht nur eine Verbindung zum Server (wie der Browser beim Datei-Download), er hat ständig viele viele Verbindungen zu vielen Servern.

Dass du in SL Probleme und rote Balken kriegst kann nämlich auch an etwas ganz anderem liegen: An Mesh, das über http läuft, und seit kurzem immer mehr verbreitet ist!

Der Viewer hat zwar eine Bandweiten-Regulierung, diese betrifft aber nur den Download und nur udp. Also eigentlich nur Texturen im Wesentlichen, und das auch nur dann, wenn die nicht über http laufen. Die Downloads per http sind genau wie die uploads des Viewers leider nicht über diesen Schieberegler gedrosselt.

Das Problem bei Meshes ist nun, dass die öfters mal ziemlich groß sind, d.h. wenn du auf einen neuen Sim kommst, dann kann es schnell mal passieren, dass du erst mal so 10MB bis 20MB an Daten runter laden musst um die ganzen Meshes zu sehen. Und wenn du wirklich Pech hast sind es noch deutlich mehr, das können bis zu 128MB sein. Bis aber z.B. 20MB Daten nebenher runter geladen werden (schließlich laden ja auch noch Texturen und andere Objektdaten usw.) kann aber dauern, mit den rund 15 bis 20 kiB/s, die noch über bleiben bei DSL Light mit maximal 46 kiB/s, da kann das locker mal 15Minuten bis 20 Minuten und mehr dauern, bis alle Mesh Objekte geladen sind. In entsprechend Mesh-Gefüllten Sims auch viel mehr. Wobei da dann noch ein weiteres Problem auftauchen kann:
Der Viewer schickt so viele Anfragen an den Server, dass die Bandbreite nicht ausreicht um alle ausreichend schnell abzuarbeiten und es kommt zum Timeout. Und der Viewer bricht den bereits teilweise erfolgten Download ab und versucht mehrmals erneut eine Verbindung herzustellen. (Passiert nebenbei auch, wenn man mit einer zu kleinen Bandbreite zu viele http Anfragen bei Texturen schickt.)

Deswegen wäre es erst mal interessant, ob der Viewer auch dann rumzickt, wenn man Mesh Downloads drosselt und http-Texturen mal deaktiviert hat. [Ich bezieh mich hier mal auf Firestorm als den meist verwendeten Viewer]
Dazu öffnet man im Firestorm die Einstellungen und stellt unter Grafik-Rendering die HTTP Texturen ab, so dass die wieder über udp laufen und gedrosselt werden können.
Bei DSL Light (ca. 400kibits/46kiB/s)solltest du dann dein Netzwerk über den Regler auf 300 kibits drosseln, dann regelt der interne Drossel-Mechanismus zwischen 150kibits und 400kibits etwa.
Und nun kommt das wichtige:
Anschließend muss man in den Debug Settings (Strg+alt+umschalt+s) den Wert MeshMaxConcurrentRequests ziemlich runter schrauben, z.B. von den default 32 Threads auf 2 oder 3 gleichzeitige Threads. Zusätzlich kann man (derzeit nur im Firstorm) noch zwei weitere Parameter ändern um den Mesh Download zu drosseln: FSMeshRequestTimeout auf z.B. von 10s auf 50s und FSMaxMeshRequestsPerSecond von 100 auf 6. Dann landen zwar mehr Mesh Downloads in der Warteschleife des Browser, aber es werden weniger Meshes gleichzeitig herunter geladen und weniger Meshes pro Sekunde angefragt, so dass eben das Netzwerk nicht mehr so stark belastet wird. So dass eben noch ein klein bisschen "Luft" bleibt für udp Pakete, weil das Netzwerk nicht mehr zu 100%, sondern nur noch zu 90% bis 99% ausgelastet ist. Wenn es dann besser läuft mit dem Viewer kann man auch noch zusätzlich wieder http-Texturen aktivieren, allerdings sollte man dann auch dort nicht mehr als 3 oder 4 gleichzeitige http-Requests einstellen mit dem Schieberegler.

Musik-Streams gehen bei DSL Light aber trotzdem nicht mehr, während Mesh-Objekte geladen werden, die Mesh Objekte sind mit ihren 10MB bis 20MB bis zu 60MB und mehr pro Sim einfach zu groß. D.h. am besten den Musik-Stream erst dann wieder aktivieren, wenn Mesh geladen ist.

Ob Mesh geladen wird und wie viel Mesh geladen wird sieht man, Wenn man im Develop Menu --> Info --> ShowRenderInfo aktiviert, dann sieht man wie viele Mesh Objekte aus dem Cache bzw. vom Netzwerk geladen werden, wie viele Mesh Objekte gleichzeitg abgearbeitet werden, wie viele noch in der Warteschleife liegen und vor allem wie oft Mesh neu angefordert wurden, weil es ein Timeout gab.
 
Zuletzt bearbeitet:
Donnerwetter Shirley, wie immer super spitzenklasse :)
Danke, das macht sogar Sinn wenn ich mir das so überlege, und würde einiges erklären. http Texturen hab ich eh immer aus. Den Rest werd ich mal so abarbeiten und ausprobieren. Danke!

Und wenn das nix bringt eh ich auf die Suche nach Wiffels Ameisenhaufen^^
 

Users who are viewing this thread

Oben Unten