• Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
  • Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
  • Wir verwenden Cookies, um Inhalte und Anzeigen zu personalisieren, Funktionen für soziale Medien anbieten zu können und die Zugriffe auf unsere Website zu analysieren. Sie geben Einwilligung zu unseren Cookies, wenn Sie unsere Webseite weiterhin nutzen.

Metropolis-Standalone: Problem mit SimulationDataStore

argus Portal

Freund/in des Forums
Hallo

Ich möchte unter Cinnamon 19.2 einen Standalone-Server mit dem aktuellen Metropolis-
Paket einrichten (0.9.1.0).

Ich muss dazu sagen, das ich soeben erst mit Linux anfange. Ich komme von Windows 7.

Nach Start über die bash

mono /lw1/Metropolis091/bin/OpenSim.exe -gui=true

gab es erstmal diese Fehlermeldung:

Master ini file /home/myname/OpenSimDefaults.ini not found

Das File holte ich dann aus opensim-0.9.0.1.tar.gz und kopierte es an die
entspr. Stelle im System.

Dann gab es diese Meldung:

Fatal error: System.Exception: Configuration file is missing the [SimulationDataStore] section. Have you copied OpenSim.ini.example to OpenSim.ini to reference config-include/ files?
at OpenSim.OpenSimBase.StartupSpecific () [0x00039] in <716c0aeb86e94b3db6cd2842fd19e559>:0
at OpenSim.OpenSim.StartupSpecific () [0x000fe] in <716c0aeb86e94b3db6cd2842fd19e559>:0
at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00064] in <d0eb68d4ba184f59a6f9a51fda8dbe4d>:0

Ich trug diese Sektion unten in OpenSimDefaults ein:

[SimulationDataStore]
LocalServiceModule = "OpenSim.Services.SimulationService.dll:SimulationDataService"

Aber es gibt weitere Fehler:

[SERVER UTILS]: Error loading plugin from OpenSim.Services.SimulationService.dllSystem.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Services.SimulationService.dll' or one of its dependencies
File name: 'OpenSim.Services.SimulationService.dll'
at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0
at OpenSim.Server.Base.ServerUtils.LoadPlugin[T] (System.String dllName, System.String className, System.Object[] args) [0x00010] in <27fcb65751f4440c938de50ecce6c696>:0

Fatal error: System.Exception: Could not load an ISimulationDataService implementation from OpenSim.Services.SimulationService.dll:SimulationDataService, as configured in the LocalServiceModule parameter of the [SimulationDataStore] config section.
at OpenSim.OpenSimBase.StartupSpecific () [0x0019d] in <716c0aeb86e94b3db6cd2842fd19e559>:0
at OpenSim.OpenSim.StartupSpecific () [0x000fe] in <716c0aeb86e94b3db6cd2842fd19e559>:0
at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00064] in <d0eb68d4ba184f59a6f9a51fda8dbe4d>:0

Ich betreibe das ganze zunächst mit SQLite.

Hat jemand eine Idee, was hier das Problem ist ? (Außer die Person vorm Monitor).
 

argus Portal

Freund/in des Forums
Danke. Den Link werde ich mir notieren. Aber ich sehe gerade (bzw. erinnere mich), das wir hier
einen OpenSim-Bereich haben. Ich bin einige Zeit nicht mehr hier gewesen und werde es erstmal
dort versuchen.

Sorry, das meine Frage dann nochmal im Forum auftaucht. Der Thread hier kann gelöscht werden, falls
ein Mod. mitliest.
 

Aktive User in diesem Thread

Oben Unten