1. Bitte schaltet eure Ad Blocker aus. SLinfo kann nur betrieben werden, wenn es durch Werbung Einnahmen erzielt. Vielen Dank!!
    Information ausblenden
  2. Wir freuen uns, wenn du dich in unserem Forum anmeldest. Bitte beachte, dass die Freigabe per Hand durchgeführt wird (Schutz vor Spammer). Damit kann die Freigabe bis zu 24 Stunden dauern.
    Information ausblenden
  3. Wir verwenden Cookies, um Inhalte und Anzeigen zu personalisieren, Funktionen für soziale Medien anbieten zu können und die Zugriffe auf unsere Website zu analysieren. Sie geben Einwilligung zu unseren Cookies, wenn Sie unsere Webseite weiterhin nutzen.
    Information ausblenden

Neues zum Thema Proxy/Cache...

Dieses Thema im Forum "Technische Hard- & Software Probleme" wurde erstellt von Yistin Usher, 20. Januar 2011.

  1. Silvan Tobias

    Silvan Tobias Superstar

    Beiträge:
    4.575
    Zustimmungen:
    35
    Punkte für Erfolge:
    58
    Zwei Punkte dazu, die ich für wesentlich halte und die ich auch falsch gemacht habe:
    1. Als Editor nicht das eingebaute Notepad verwenden sondern tatsächlich Notepad++ für die squid.conf und store_url_rewrite.pl
    2. squid -z bzw. squid -i in der Eingabeaufforderung als Administrator ausführen und den Befehl von Hand eintippen und nicht kopieren.

    Nachdem ich das beherzigt habe, läuft Squid bei mir ohne Fehlermeldungen.
     
  2. Yistin Usher

    Yistin Usher Guest

    Richtig Silvan, da fällt man als nicht-Linuxer schnell mal drauf rein:

    Wenn schon Windows-Editor, dann bitte wirklich den "Editor" nehmen und nicht das Notepad.

    Hintergrund dazu:
    Squid kommt aus der Unix/Linux-Welt. Die Config-Dateien sind "ASCII"-codiert (ASCII: American Standard Code for Information Interchange. Das ist im Grunde eine Tabelle, die festlegt, welcher Buchstabe mit welcehr Zahl im PC dargestellt wird - merke: Prozessoren kennen nur Zahlen... Im ASCII wird ein "A" durch die Zahl 65 repräsentiert).

    Windows arbeitet meist schon mit neueren ISO-zeichensätzen - ebenfalls so eine Tabelle, aber eine ander Codierung. Die ist obendrein noch national unterschiedlich, jeder kennt fermutlich die Texte, in denen statt einem "ä" ein Kästchen steht... da sind zwei solche Tabellen "kollidiert".

    Schreibt man mit dem Notepad in der Konfigurationsdatei, ändert das Pad ungefragt diese Zeichentabelle - und Squid kann die Datei nicht mehr ohne weiteres bzw. ohne Fehler lesen.
    Notepad++ erkennt die Tabelle und behält sie bei, der Standard-Editor (Steht bei XP im Zubehör) ist per se ein ASCII-Editor.
     
  3. Das Problem beim Wechsel zwischen Unix und Windows ist nicht so sehr die Zeichensatzkodierung (ob nun UTF-8 oder ISO-8859-15, man findet sowohl hüben wie drüben dafür Editoren wie Sand am Meer), sondern schlicht und einfach die Darstellung des Zeilenendes.

    Es gab und gibt im seeligen ASCII-Standard zwei Sonderzeichen, nämlich einmal CR (Carriage Return für Wagenrücklauf) und LF (Linefeed, also Zeilenvorschub).

    Windows und seine Standardwerkzeuge braucht, um bei einer Datei eine neue Zeile zu notieren, standardmässig CRLF. Unter Unix dagegen reicht schon LF aus.

    Das führt dazu dass wenn man eine normale Textdatei von Unix nach Windows überträgt man erst einmal fast alles nur in einer Zeile liest.

    Übrigens leere ich auch bei aktivem Squid den Viewercache eher selten, da ja nicht nur die Texturen in diesem gecached werden, sondern auch das Inventar des Avatars und ich nicht ständig Lust darauf habe, nach dem Einloggen warten zu müssen bis das alles wieder zur Verfügung steht - und ja auch inzwischen der Object Cache (==Beschreibung aller Prims einer Sim) brauchbar genug funktioniert.

    Mein Cache unter Linux hat momentan ca. 12 GB voll, Highwatermark habe ich auf 99% eingestellt und ~150.000 Texturen damit lokal auf der Festplatte vorrätig. Die Hitrate auf den Squid in einer normalen Sitzung liegt bei mir meistens irgendwo im Bereich von 60-70%.
     
  4. Yistin Usher

    Yistin Usher Guest

    Stimmt, CR und CR/LF hatte ich noch übersehen, das kommt noch oben drauf.

    Auch das schraubt das Notepad von Windows meist um, da ist der Text dann umgebrochen - und die Datei u.U. nicht mehr funktionsfähig.
     
  5. Seca Skosh

    Seca Skosh Aktiver Nutzer

    Beiträge:
    256
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit der Datenausführungsverhinderung hat das hier jedenfalls nichts zu tun.

    Habe Notepad++ verwendet. commandprompt mit adminrechten ausgefuehrt. befehle eingetippt (wieso eigentlich nicht kopieren? kopieren geht auch, zb. verzeichniswechsel werden auch mit kopierten befehlen ausgefuerht.)

    dann mal squid ordner geloescht. Squid aus service (dienste) entfernt (geht, wie vermutlich immer schon und windowslogisch nur mit brechstange also ueber die registry mit anschliessendem neustart)

    squid neu installiert. Datenausfuerhungsverhinderung so gelassen (mit nun ca 17 exedateien aus squid in der liste von dateien, die dieser funktion icht unterliegen sollen, spielt ja eh keine rolle) .

    schliesslich wieder squid-z und dann squid-i, klappt, erneut start mit dem dienste programm.
    Trotzdem immer 1067.
    Googlen nach 1067, komme nach 1 minute zum link MySQL - Fehler beim Starten | Datenbanken allgemein | wer-weiss-was, den ich nach 5 minuten wieder verlasse um nicht 60 minuten lang nichts zu verstehen.

    Ich frag mich langsam echt, wieso das bei mir nicht klappt, obwohl ich auch windows habe wie ihr... ne moment.. oder, WEIL ich windows habe...
     
  6. Lucy Schlesinger

    Lucy Schlesinger Aktiver Nutzer

    Beiträge:
    186
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast du mal versucht auf der Console mit Admin rechten auszuführen ?
    Vllt spuckt Squid dann eine verständlichere Fehlermeldung aus.
     
  7. Seca Skosh

    Seca Skosh Aktiver Nutzer

    Beiträge:
    256
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Aber ja.. ich habe immer die admin einstellung. Arbeite sowieso als admin mit allen rechten, falls das was ausmacht. . bzw auf der console kommt nichts ausfuerhlicheres als mit dem dienste-prog.
     
  8. Yistin Usher

    Yistin Usher Guest

    Vom Microsoft Developer Network , gefunden bei Google:

    Mehr sagt der Fehler 1067 nicht aus: Irgend ein Prozess hat sich unerwartet verabschiedet. Das kann irgend ein Programm ein, ein MySQL, oder eine Textverarbeitung oder ein Squid. Eine direkte Aussage zu den Ursachen kann man aus dieser Meldung nicht ableiten.

    Unter Windows ist das oft die Ausführungsverhinderung, die einen Prozess bereits beim Start abwürgt. Es können auch andere Gründe vorliegen: Es liegt ein Fehler in der Config-Datei vor, z.B., oder es fehlen Zugriffsrechte.

    Hinter den eigentlichen Ursachen muss man dann herforschen, hilft nix. Bei allen Programmen aus der UNIX-Welt sind dann die Logfiles die erste Anlaufstelle.

    Da sind zum einen die Windows-eigenen Logs in der Verwaltung, zum anderen könnte es sich lohnen nach folgenden Dateien zu fahnden:
    - access.log
    - cache.log
    - store.log
    Das sind die Squid-eigenen Log-Files, je nach Konfiguration liegen die irgendwo im System (ich hab Squid nicht unter Windows laufen, ich weis ned genau wo).
    Dort finden sich in aller Regel Hinweise, was da schiefgelaufen ist.
     
  9. Gina Masala

    Gina Masala Guest

    Seca Wenn du der Windoof Anleitung gefolgt bist, sollten die logs hier stehen:
    "C:\squid\var\logs"

    Versuch mal nicht den Dienst zu starten, sondern starte squid mit der Konsole. einfach "C:\squid\sbin\squid.exe" starten ohne Parameter.
    Vielleicht haut das so klarere Fehlermeldungen raus.
     
  10. questargon Edelmann

    questargon Edelmann Aktiver Nutzer

    Beiträge:
    497
    Zustimmungen:
    6
    Punkte für Erfolge:
    19
    Yay. Ich habs auch unter Linux zum rennen gebracht :grin:. Danke dir für deine Anleitung, Barth. Das war ne prima Vorlage.

    Allerdings musste ich mir das Quellcode-Paket laden und selber compilieren, da mein Linux die Version Squid-2.7 nicht mehr in seiner Paketverwaltung hat (Fedora 14).

    Wenn man das macht, sollte man unbedingt die Konfiguration vor dem Kompilieren wie folgt starten (Unix-Freaks wissen, was gemeint ist ;) ):

    Code:
    ./configure --enable-async-io
    
    Wenn man das vergisst, gibt es kein "aufs" im Squid und die "cache_dir"-Anweisung in der "squid.conf" schlägt fehl.

    Meine Cache-Parameter schauen jetzt so aus:

    Code:
    cache_dir aufs /usr/local/squid/var/cache 16384 16 256
    cache_mem 256 MB
    
    Tip für euch: Der Squid 2.7 benutzt normalerweise 8 MB RAM-Cache. Das kann man über die Anweisung cache_mem (s.o.) anpassen. Dann wirds sogar noch schneller. ;)

    Achja: Damit man mit anderen Computern auf den Squid-Cache des Linux-Rechners zugreifen kann, sollte man in etwa sowas in die "squid.conf" schreiben:

    Code:
    acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
    
    Vergisst man das, dann will squid mit den anderen Computern nicht reden. ;)

    Man beachte die /16 am Ende der IP. Das heißt, dass alle IP-Adressen, die mit 192.168... beginnen zulässig sind. Das sollte normalerweise passen, auch bei Fritz-Boxen und ähnlichen Routern. In Barths Config steht noch /24, das wären dann alle IPs mit 192.168.0 am Anfang. Da könnte es Probleme geben. Also besser auf /16 setzen.

    MfG
    Questargon
     
  11. Silvan Tobias

    Silvan Tobias Superstar

    Beiträge:
    4.575
    Zustimmungen:
    35
    Punkte für Erfolge:
    58
    Ich habe mir jetzt einen Teil der Festplatte abgezwickt und eine logische Partition mit 80 GB erstellt. Dorthin kam dann der Cache des Squid und auch der restliche kleine Cache des Viewers.

    Da doch recht viele Dateien anfallen und auch wieder gelöscht werden, neigt das ganze zum Fragmentieren, und so muß ich nur einen kleinen Teil der Platte regelmäßig defragmentieren, was der Geschwindigkeit sowohl des Zugriffs als auch der Defragmentierung entgegen kommt.
     
  12. Simba Fuhr

    Simba Fuhr Guest

    Juhuu, ich hab den Cache auch endlich hin bekommen :)

    Ich hab mir eine kleine Batch geschrieben, weil ich den Cache jetzt vorkonfiguriert auf einer externen Festplatte eingerichtet habe.

    Ich bastel im Moment an einem Programm, dass das ganze vereinfacht und das man nur starten muss um den Cache vorkonfiguriert von der externen Festplatte zu starten :)

    Danke an alle hier für die Aufschlussreiche Anleitung.
     
  13. Herm Piek

    Herm Piek Gesperrt

    Beiträge:
    133
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Im Grunde ist es egal, was du setzt, solange die Rechner die vom Squid profitieren sollen als dem Netzwerk zugehörig gerechnet werden.
    Bei Barth stand übrigens eine /23, was 255.255.254.000 als Subnetzmaske bedeutet (die Notation zählt die Bit, die auf Eins stehen. (CIDR) http://www.ietf.org/rfc/rfc1517.txt. Stimmen die Stellen, wo die Maske auf eins steht mit der eigenen IP-Adresse überein, gilt die entsprechende Adresse als zum Netz gehörig). Das sind 510 Host beginend mit der 192.168.0.1 bis 192.168.1.254.

    Da einige Router 192.168.0.x und andere 192.168.1.x als Standard verwenden, ist die /23 die sichere Methode. Ich nehme lieber genau die Maske, die wirklich zu meinem Netz passt, und das ist die /24 also, 255.255.255.0 (254 Hosts). Ausserdem stehen in der Beispiel Konfiguration vom Squid noch andere als privat definierte Netze drinnen, die ja auch nicht stören, man KANN sie also ruhig drinnen lassen.

    Warum ich das so ausfühlich schreibe? Weil es hier um Administration geht, von der muss man Ahnung haben oder sowas halt lassen. Das geht jetzt nicht gegen dich, sondern meine ich ganz allgemein. Da steh ich auch zu, selbst wenn gleich ein paar Leute beginnen Steine zu werfen.

    Meiner Frau habe ich bereits 1995 das O'Reilly TCP/IP Netzwerk-Administration Buch in die Hand gedrückt, damit sie lernt zu verstehen, was sie eigentlich benutzt (Für windows 95 gab es die ersten ISDN Karten und CAPI Subsysteme, Linuxtreiber waren schon vorhanden, sofern man sie sich selber complilierte).

    Hier Robert Scheck | Internet | IP-Rechner/-Subnettierung kann man sich sein Netz auch selber rechnen, schön auch die Darstellung der Bit-Maske. Wer genau hin schaut und ein wenig probiert, erkennt gut optisch, ob ein Rechner in das Netz passt oder nicht.

    LG,
    Herm
     
  14. Yistin Usher

    Yistin Usher Guest

    Da werf ich bestimmt nicht mit Steinen - nur mit grünen Daumen.
     
  15. questargon Edelmann

    questargon Edelmann Aktiver Nutzer

    Beiträge:
    497
    Zustimmungen:
    6
    Punkte für Erfolge:
    19
    *hochscroll, Barths post such, Herms Post such* Hmm, ich seh ne /24, jedenfalls in deinem Zitat von Barths Config. Is aber egal, denn was du geschrieben hattest, stimmt schon.

    Wenn man es genau nehmen will, sollte man die Netzmaske so eng setzen wie möglich. Allerdings ist das, was ich vorgeschlagen habe, nicht grundsätzlich falsch, denn soweit ich weiß, ist der IP-Bereich 192.168.x.x. sowieso für private Netzwerke vorgesehen. Und die meisten Leute haben eh nicht mehrere, voneinander getrennte private Netzwerke nebenher laufen. Und wenn doch, dann wissen die eh Bescheid über Netzwerkkonfigurationen. :smile:

    Wer also die Maske exakt setzen will, sollte unter Windows/Linux/Mac erstmal rausfinden, welche IP-Adresse er zugewiesen bekommen hat. Dann macht man aus der letzen Nummer eine "0" und hängt das /24 dran.. fertig.

    Bei mir daheim wäre das zum Beispiel:

    192.168.155.0/24

    Und wer es GANZ genau nehmen will, der trägt in die Config exakt NUR die IP-Adressen der Recher ein, die zugreifen dürfen, und hängt ne /32 dran.

    Wären bei mir

    192.168.155.32/32
    192.168.155.37/32

    Dann ist man auf der GANZ sicheren Seite.

    MfG
    Questargon
     
  16. Herm Piek

    Herm Piek Gesperrt

    Beiträge:
    133
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Unter Windows 7 geht es am schnellsten, wenn du die Windowstaste+Pause drückst (Startseite Systemsteuerung), dann auf der linken Seite die "Erweiterte Systemeinstellungen" aufrufen. jetzt in dem Fenster auf den Reiter "Erweitert" gehen und die Umgebungsvariablen bearbeiten.

    Du kannst jedes Programm mit Adminrechten ausführen, wenn du auf eine Verknüpfung oder ein Programm mit rechtsklick draufgehst und dann "Als Administrator ausführen" anwählst.
    Den Explorer als Admin auszuführen geht in etwas so:
    Auf Start klicken und im "Programme/Dateien durchsuchen"-Suchfenster einfach ein "e" tippen. Die Suche bietet dir jetzt bereits an oberster Stelle den "Windows-Explorer" an, den du nur mit Rechtsklick, "Als Administrator ausführen" anwählst.

    Herm
     
  17. Herm Piek

    Herm Piek Gesperrt

    Beiträge:
    133
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Squid 2.7 for Windows
    :: squid -r [-n servicename] (removes the servicename Squid service)

    C:\squid\sbin\squid -r

    hätte es auch getan (natürlich mit Admin-Rechten). Dann das Squid-Verzeichnis löschen.

    Hat man den Fehler erst einmal gemacht (der Dienst kann nicht mehr gelöscht werden, weil das Programm nicht mehr existiert), dann auf der Kommandozeile "cmd.exe" (starten mit Admin-Rechten siehe Post zuvor) und dort dann eingeben:
    sc delete squid
    Dannach dennoch das System einmal neu starten (meine Empfehlung nur, ob's wirklich notwenig ist weiß ich nicht, aber ich lasse mich nicht gerne überraschen)

    Herm
     
  18. Nicoletta Schnute

    Nicoletta Schnute Forumsgott/göttin

    Beiträge:
    8.042
    Zustimmungen:
    729
    Punkte für Erfolge:
    123
    Hat jemand schon den Firestorm dazu überreden können mit squid zu harmonieren?

    Der squid logt die Texturen, speichert sie aber nicht. Status NONE
     
  19. Silvan Tobias

    Silvan Tobias Superstar

    Beiträge:
    4.575
    Zustimmungen:
    35
    Punkte für Erfolge:
    58
    Ich wüßte nicht wo der Unterschied beim Squid sein sollte ob der jetzt die Texturen für den Phoenix oder den Firestorm cacht.
    Ich habe ihn eingestellt und habe den Eindruck es funktioniert.
    Aber ich schaue heute Abend mal ins Log.

    Nachgeschaut (Nachtrag)

    irgendwas ist wirklich komisch.
    Ich werde aus den Logs nicht so richtig schlau, aber mit fehlen definitiv ganz viele tcp_hit
     
  20. Nicoletta Schnute

    Nicoletta Schnute Forumsgott/göttin

    Beiträge:
    8.042
    Zustimmungen:
    729
    Punkte für Erfolge:
    123
    Mir viel es auf weil der Firestorm bis zu 15 FPS weniger macht als der neue Phoenix bei 40 FPS. Ohne HTTP texture bringt der Firestorm sogar bis zu 6 FPS mehr als mit.
    Das ist sehr ungewöhnlich ...
     

Diese Seite empfehlen

  1. Diese Seite verwendet Cookies, um Inhalte zu personalisieren, diese deiner Erfahrung anzupassen und dich nach der Registrierung angemeldet zu halten.
    Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden